Development field is not returning any issues in JQL

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

   

Summary

No results or out of sync after running the JQL query below:

development[commits].all>0
development[pullrequests].all>0
development[branches].all>0

Environment

  • Jira 8.20.10
  • Bitbucket

Diagnosis

  • Has tried recreating the Application Links and no errors returned on both incoming and outgoing authentication.
  • "Development" system field is present via the Custom Field page. Next, ensure the field customfieldsearcherkey is exist in the customfield table. 

    select * from customfield where customfieldtypekey like '%development%integration%' and customfieldsearcherkey is not null;

  • Reindex and Integrity Checker

Cause

The development panel summary cache is stored under the table:

  • AO_575BF5_DEV_SUMMARY (This is where all the issue-specific data is stored as well as when and where the data came from)

In order to JQL search for commit data the code is utilizing these tables which are only populated when reaching out via API (theory, this will be validated) by loading an issue.

Solution

Suggestion 1: load the issue page manually or verify the issue id is stored in the AO_575BF5_DEV_SUMMARY table.

Suggestion 2: follow the KB article #option 2 solution in JIRA development panel information is out of sync with Bitbucket Server

Suggestion 3: run a script to refresh the cache
 

  • Please find the issue id by running the SELECT SQL query below: 

    select id from jiraissue where project = (select id from project where pkey = '<project_key>');


    (info) Replace <project_key> with the desired project key.

  • Run the following API call on an issue that is affected (we need the actual issued, not the key): 

    GET <baseurl>/rest/dev-status/1.0/issue/summary?issueId=<issueid>

    (lightbulb)You can iterate the API to run on a script for multiple issues. Once this is done, all dev info should be in the DB and available for a Lucene search.


Last modified on Aug 23, 2022

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.