Different ordering of issues in the Filter Results gadget

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Problem

When the owner of the shared-dashboard clicks on one of the column headings in the table, JIRA will re-sort the table by that column, and this will then become the default sort order of that dashboard. 
When a different user now loads that dashboard, it will be sorted by the column that the owner clicked on. In contrast, if a different user (not the owner) clicks on a column heading, the table will only be temporary re-sorted.

Diagnosis

Diagnostic Steps

  • Do the same steps for JIRA 6.1.4 and JIRA 6.4.11 :

    1. Login to JIRA as admin
    2. Add "Filter Results" gadget in dashboard
    3. Choose one of the saved filter and Save.
    4. Go to {{Issue > Search for Issue > Click on the Filter}} added in the step 2
    5. Try change the Filter configuration by changing the order of the issue: Eg: _ORDER BY assignee ASC_
    6. Save the filter
    7. Click on the Dashboard , try to change the order by clicking on any of the header in the gadget .
    8. Go to other pages and come back to Dashboard page again.
    8. Check if the order of the "Filter Results" gadget is same with the one configured in the Filter in step 5.

    *For version 6.1.4:*
    The order of the item in the "Filter Results" gadget ordered based on the Saved Filter and the order is maintained even after tried to change the order , go to other pages , then come back to the Dashboard Page.This is the expected and default behaviour of the filter

    *For version 6.4.11:*
    The "Filter Results" gadget display the issue order based on the last action performed by the admin which is by clicking on the header of the gadget and is not following as configured in the Saved Filter.

Cause

It is a bug for JIRA 6.4.10 and 6.4.11 as stated in  JRA-47039 - Getting issue details... STATUS  as the behaviour differ compared to JIRA 6.1.4

Workaround

The dashboard owner should not able to change the default order of the rows in the gadget just by clicking on a column.But, there are two possibilities for the "Filter Results" gadget to use the filter which has been sorted in order by the user. There are two methods that you can try to do this:

  • Method 1 : User can copy the shared dashboard and shared filter of the owner.
    In order to do this, the user should have the ownership for the filter and dashboard. The steps to do these are : 
  1. Copying Shared Dashboard] of the owner.
  2. Cloning the Filter
  3. Use the cloned filter in the step 2 to the shared dashboard that user has copied in step 1 above. This is because the user will have the full ownership for the dashboard and able to manage the order of the filters in the dashboard on their own

    NOTE : To access the 'Shared Dashboards' and 'Shared Filter' feature , ensure that you are logged in as a user with the JIRA Administrators global permission

    User who have the JIRA Administrators permission (and not the JIRA System Administrators permission) cannot perform certain functions as stated here.

 

  • Method 2: Admin can copy their own shared dashboard and shared filter and change the ownership of the copied dashboard and filter to the user.The steps to do these are :
  1. Copying Shared Dashboard
  2. Cloning the Filter
  3. Use the cloned filter in the step 2 to the shared dashboard that admin has copied in step 1 above.
  4. Changing the Ownership of a Shared Dashboard copied in step 1 to the user. 
  5. Changing the Ownership of a Shared Filter cloned in step 2 to the user.
  6. Now user can search for the dashboard created by the admin and use it.

Last modified on Nov 2, 2018

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