Disable the invite user option from Jira App on Slack
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When you are sharing a ticket link on Slack, the Jira App notifies you that there are users who need access to the Jira Service Management with the following message.
To view this link, <username> needs access to Jira Service Management on <instance name>. Do you want to invite them?
Cause
This is caused because the users invited directly to the Slack channel don't belong to the agent scope in the JSM. It can raise an issue when users who don't need access to Jira are invited to it, turning very hard the administration task for those who have a lot of users inviting individuals from outside of the organization or (even inside the organization) that should not have access to the system.
- Site admins will always see it because they can invite users regardless.
Solution
There is a feature request to disable this option completely even for Admin users. With the possibility to disable this option, the Administrators will be able to control if they want their users to invite other users or not.
JRACLOUD-78922 - Possibility to disable the invite users to Jira button from Slack
This is a site-expected behavior for the admin users. Another aspect that is relevant to this scenario is the User access settings in the admin scope. That's possible to prevent other agents from inviting agents to the site. Jira App will honor this configuration only for the agent users. Changing the JSM product invitation permission to "Don't allow invite" will avoid this message to the agents, but site-admin will still be allowed to invite agents.