Email requests fail with Unable to retrieve sender address error message
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Incoming emails sent to JSM projects fail to create issues due to the following error logged in the mail handler logs:
Diagnosis
The failed email can be retrieved by accessing the processing log, follow the below steps to retrieve it:
From your service project, select Project settings , and then Email requests.
Under the account you want to see the processing log for, select View logs.
Select Processing log.
To find specific messages, search by email address, subject line, or issue key, or filter by status and date range.
To download a message as an EML file, select More (...) > Download raw email message.
Once the .eml file is retrieved, use any Mail app for opening the file and view its content in raw mode, then locate the "From" header.
The header appears to have additional/invalid characters causing Jira to not read those properly.
Cause
Jira will use as issue reporter the email address found in the "From" header in the following syntax
- From: Any username <email@domain.com>
However, if header contains additional characters enclosing the email address, or is missing the enclosure characters ( '<' and '>'), Jira will fail to process the email resulting in the "Unable to retrieve sender address".
Some examples of invalid data found in the From header are the following:
- From: Any username <<email@domain.com>>
- From: Any username <$%_EAS"%email@domain.com$%_AEP>
- From: Any username email@domain.com
Solution
Ensure that the email address is enclosed with single '<' and '>' characters, for example:
- From: Any username <email@domain.com>
Since the "From" header is populated by the Outgoing email server (On the client's side). This should be checked with the Email administrator of the email domain that failed to create the issue in order to ensure they send the header as Jira expects it.