Email requests from Jira Service Management are not processed
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Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When one mailbox configured in a Jira Service Management project has a large number of unread messages, these messages might never be processed and it can impact other JSM projects.
Cause
In these cases, the Mail Puller job fails, throwing this error in atlassian-jira-incoming-mail.log
:
2021-05-20 12:34:55,500-0300 ERROR [] Caesium-1-4 anonymous Messaging Error when MailPullerWorker pulls emails from myaccount@mycompany.com: * BYE Jakarta Mail Exception: java.net.SocketTimeoutException: Read timed out
As indicated in the error, it times out when retrieving the mail messages, so it never manages to process them.
Solution
Log into the indicated mailbox in the error and check the reason for the excessive number of messages.
Delete those that are not needed and move the others to another folder. Move them back in smaller batches until all are processed or deleted.