Email responses from customers are showing with "[if gte mso 9]" in issue comments
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When customers reply to issues using MS Outlook, you may see that this response has a code prefix similar to the below ones when added as comments to the issue:
<!--[if gte mso 9]> <!--[if gte mso 9]> Normal 0 false false false false EN-IE JA X-NONE <!--[if gte mso 9]>
<![if gte mso 9]> <![if gte mso 9]> 98 Clean DocumentEmail false false false EN-US X-NONE X-NONE <![if gte mso 9]> <!--[if gte mso 10]>
Environment
Jira Service Management Cloud
Diagnosis
The EN-IE JA X-NONE error is caused when an email is copied from MS Word or MS Outlook or if the copied content has an empty space. Sometimes, users using CodeTwo signatures to automatically add signatures to their Outlook emails also face the same issue.
Cause
This is due to the formatting of MS Word and MS Outlook and eventually, this code is included along with the copied content. Since these responses are reply or forward emails, it ignores the content below the quoted line and only pastes the content of the email.
Solution
Below are the possible solutions to avoid this:
- If the user is copying text from Word to Outlook, you can suggest they paste it first to a text editor and then copy it to paste in the email
- If the user is forwarding emails, you can suggest the user create a new email with the copied text with the service project mail ID in the TO address
- If the user is using CodeTwo signatures in their automatic replies, suggest they remove it or modify the mailbox settings to not use it for Jira responses