Emailed requests are not created with an error in the logs indicating that a custom field is not correctly filled in


Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

Emailed requests are not created and in the logs for the mail handler, a message similar to the following is shown:

Your request could not be created. Please check the fields have been correctly filled in. <Custom field name>

Diagnosis

In order to diagnose this issue, please:

  1. Visit the project
  2. Click on Project settings (on the left side bar)
  3. Click on Email requests (on the left side bar)
  4. Click on View logs (for the affected mail handler)
  5. Confirm if you see a message like the following:
Your request could not be created. Please check the fields have been correctly filled in. <Custom field name>

Cause

The cause for this is due to the workflow used by that request type having a Validator in the Create transition which requires a value for that custom field.

Solution

To correct this issue, please do one of the following:

  • Remove the Validator from the Create transition for the workflow used by that request type
  • Modify the request type used for the mail handler to specify a default value for the custom field

More information on how to perform these actions can be found at:



Last modified on Jan 30, 2024

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