Emailed requests are not created with an error in the logs indicating that a custom field is not correctly filled in
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Emailed requests are not created and in the logs for the mail handler, a message similar to the following is shown:
Your request could not be created. Please check the fields have been correctly filled in. <Custom field name>
Diagnosis
In order to diagnose this issue, please:
- Visit the project
- Click on Project settings (on the left side bar)
- Click on Email requests (on the left side bar)
- Click on View logs (for the affected mail handler)
- Confirm if you see a message like the following:
Your request could not be created. Please check the fields have been correctly filled in. <Custom field name>
Cause
The cause for this is due to the workflow used by that request type having a Validator in the Create transition which requires a value for that custom field.
Solution
To correct this issue, please do one of the following:
- Remove the Validator from the Create transition for the workflow used by that request type
- Modify the request type used for the mail handler to specify a default value for the custom field
More information on how to perform these actions can be found at: