Empty Backlog Even Though Issue Exist

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Symptoms

Backlog is empty with "There are currently no issues in the backlog" message is shown even though there are issues exist.

Diagnosis

  1. Sprint field is applicable in Global Project and Issue Type
  2. Total number of issues are shown via Tools > Configure > Columns
  3. In the database, run following queries:

      1. check what is the Sprint type custom field used as the default

        select * from propertynumber where id in (select id from propertyentry where property_key like '%GreenHopper.Sprint.Default%');
        

        (info) take note of the propertyvalue column as this is the Custom Field ID

      2. check if issue has value in this custom field

        select * from customfieldvalue where customfield=<Customfield_ID>;
        

        (info) if there is no result return, proceed with the next SQL query

      3. check if there any Sprint type customfield

        SELECT * FROM customfield where customfieldtypekey like '%sprint%';
        
      4. check if the other Sprint Type custom field has value:

        select ISSUE from customfieldvalue where customfield=<Other_customfield_ID>;
        

        (info) if there any result return, take note of the customfield column and proceed to Resolution section

Cause

The default Sprint used for default has been changed.

Resolution

  1. Backup JIRA Software database
  2. Update database manually

    Update propertynumber set propertyvalue=<customfield> where id=<property_id>;
    

    (info) customfield should referring to Sprint type custom field that has value. The property_id is referring to the ID return in the First SQL query

  3. Restart JIRA Software
Last modified on Feb 26, 2016

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