Empty Backlog Even Though Issue Exist
Symptoms
Backlog is empty with "There are currently no issues in the backlog" message is shown even though there are issues exist.
Diagnosis
- Sprint field is applicable in Global Project and Issue Type
- Total number of issues are shown via Tools > Configure > Columns
- In the database, run following queries:
check what is the Sprint type custom field used as the default
select * from propertynumber where id in (select id from propertyentry where property_key like '%GreenHopper.Sprint.Default%');
take note of the propertyvalue column as this is the Custom Field ID
check if issue has value in this custom field
select * from customfieldvalue where customfield=<Customfield_ID>;
if there is no result return, proceed with the next SQL query
check if there any Sprint type customfield
SELECT * FROM customfield where customfieldtypekey like '%sprint%';
check if the other Sprint Type custom field has value:
select ISSUE from customfieldvalue where customfield=<Other_customfield_ID>;
if there any result return, take note of the customfield column and proceed to Resolution section
Cause
The default Sprint used for default has been changed.
Resolution
- Backup JIRA Software database
Update database manually
Update propertynumber set propertyvalue=<customfield> where id=<property_id>;
customfield should referring to Sprint type custom field that has value. The property_id is referring to the ID return in the First SQL query
- Restart JIRA Software