Epics Do Not Show Up in Epic Panel due to Wrong Epic Issue Type

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Symptoms

When a user intends to create any Epic in the Epics Panel, the default issue type for the Epics is not Epic issue type (for example bug instead of epic).

Cause

Per  GHS-6927 - Getting issue details... STATUS , this most likely occurs when the user deletes/changes the JIRA Software's default issue types so JIRA Software won't map it correctly to the exact issue type.  

Resolution

  1. This is a dangerous operation. Be careful to back up your database prior to attempting it.

    BACK UP YOUR DATA USING THE INSTRUCTIONS AT Backing Up Data PRIOR TO ATTEMPTING THIS PROCEDURE


  2. Identify the 'Issue Type' IDs for the Issue Types used by JIRA Software with the following SQL.

    select id, pname from issuetype where pname in ('Epic');
    • Epic
    Expand for further steps for finding the Issue Type IDs...

    Go to Administration > Issues > Issue Types

    1. Click on the 'Edit' link for the following Issue Types and note down the IDs
      1. Epic
    2.  For example if the url is http://servername/secure/admin/EditIssueType!default.jspa?id=6 then the ID is 6.
  3. Run the below SQL in the JIRA Software database to locate the current configuration data:

    select propertyvalue from propertytext where id = (select id from propertyentry where property_key ='SCRUM_DEFAULT_TEMPLATE_CONFIGURATION');
  4. The returned text will be a long one and we recommend copying the contents from the displayed output to a text editor of your choice.
  5. Modify the XML output from the previous step (using the text editor) to so that the below entries point to the right custom field ids which we identified in the initial step.

    XML AttributeRelated Custom FieldSample XML
    gh.issue.storypointsStory Points
    <entry>
      <string>gh.issue.storypoints</string>
      <string>customfield_10900</string>
    </entry>
    gh.issue.rankingfieldRanking (Obsolete) (info) This is from versions of JIRA Agile (now JIRA Software) prior to 6.x.

    <entry>
    <string>gh.issue.rankingfield</string>
    <string>customfield_10002</string>
    </entry>

    gh.issue.labelfieldEpic/Theme

    <entry>
    <string>gh.issue.labelfield</string>
    <string>customfield_10001</string>
    </entry>

    gh.issue.businessvaluesBusiness Value

    <entry>
    <string>gh.issue.businessvalues</string>
    <string>customfield_10004</string>
    </entry>

    gh.issue.flaggingfieldFlagging

    <entry>
    <string>gh.issue.flaggingfield</string>
    <string>customfield_10000</string>
    </entry>


    The XML also includes these additional values for the following 'Issue Types':

    XML AttributeRelated Issue TypeSample XML
    gh.issue.storyStory

    <entry>
    <string>gh.issue.story</string>
    <string>7</string>
    </entry>

    gh.issue.taskTechnical Task

    <entry>
    <string>gh.issue.task</string>
    <string>8</string>
    </entry>

    gh.issue.epicEpic

    <entry>
    <string>gh.issue.epic</string>
    <string>6</string>
    </entry>

    gh.issue.businessvaluesBusiness Value

    <entry>
    <string>gh.issue.businessvalues</string>
    <string>customfield_10004</string>
    </entry>

  6. Once the XML is prepared, update back the database with the below SQL command: 

    update propertytext set propertyvalue = <copy the contents from the text editor containing the XML here> where id = (select id from propertyentry where property_key ='SCRUM_DEFAULT_TEMPLATE_CONFIGURATION');
  7. (Optional - Oracle Only): Commit the changes to database by an explicit COMMIT.
  8. Start JIRA Software.

  9. Reindex JIRA Software and test to see if you can use JIRA Software without errors.

Last modified on Feb 26, 2016

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