Error - "Actor does not have permission to view."

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

You might see one such error message:

"Actor does not have permission to view one or more issues, or the issue was deleted "
"Actor does not have permission to view the event that triggered this execution'

Diagnosis

  • There were multiple rules scheduled on the issue-created events. One of the actions was to delete the issue. While one action had deleted the issue, a parallel execution was trying to look for the same issue.
  • Sometimes the rule actor does not have the required permissions.

Cause

  1. Parallel executions due to which the deleted issue got picked by the automation.

    This is a known limitation and we have a below request to improve this behavior.

    • AUTO-32 - Rule orchestration - allows the switch between parallel and sequential execution of Automation Rules
  2. The rule actor does not have the required permission to execute the rule actions.
  3. The atlassian-addons-project-access role does not have the required permissions.

Solution

  1. The solution to Cause 1:
    1. First, the Issue Creation Trigger, when a rule is triggered by issue creation, immediately attempts to perform the actions defined within it (these actions vary between a few seconds). If one of those actions involves accessing the issue (viewing, modifying, transitioning, or even deleting it), the 'actor' executing the rule must have the necessary permissions to perform these actions on that issue.
    2. Due to multiple automation rules running during the Issue Creation event for the project, sometimes the rule might fail the permission check if the delete issue event is completed before this request.
    3. In a nutshell, Automation for Jira operates using a rule processing queue to handle rule executions in your instance efficiently. To ensure optimal performance, rule executions are queued, and the number of simultaneous processes isn’t controlled.
    4. Considering the project hosts multiple automation rules triggered by the Issue Creation event, it's important to note that some rules may not execute immediately. Instead, they are queued for processing and will be actioned after a brief delay. However, since the "Delete issue" action was executed in one of the initial queued items, subsequent rules may encounter difficulty associating the Issue ID with the log. Consequently, they may display a generic error message such as "Actor does not have permission to view the event that triggered this execution".
    5. Combining rules with the same trigger would also help in this scenario.
  2. The solution to Cause 2:
    1. Check the rule actor and permission scheme to ensure the actor has the correct permission to perform actions.
    2. Check if the issue security scheme is blocking the rule actor from performing actions and correct the permissions.
  3. The solution to Cause 3:
    1. The Automation for Jira actor will only work if the atlassian-addons-project-access role has the desired permissions.

Helpful resources:

Last modified on Oct 11, 2024

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