Error "Attribute is in error" while updating an Assets Object

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Some users might receive the  "Attributes are in error" or "Attribute is in error" message while trying to update an Assets Object.

Environment

Jira Service Management with Assets

Diagnosis

The error message "Attributes are in error" will be displayed whenever trying to update anything in an Object that has a Jira User attribute type along with the error "Users(s) USERNAME not found in Jira"

Cause

The user doesn't belong to any Group that has the 'Browse Users' Global Permission.

Solution

  1. Navigate to Administration > System > Global Permission

  2. Make sure that the affected user belongs to any of the Groups added to the 'Browse Users' Global Permission.

Updated on March 5, 2025

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