Error linking issues using Automation
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When using the "Link issues" action in an automation rule, it fails with an error message indicating a permissions problem:
(Issue does not exist or you do not have permission to see it., You must provide one of 'inwardIssue' or 'outwardIssue'. (issuelinks)).
Diagnosis
To reproduce the error:
- In an automation rule, add a "Link issues" action.
- Configure it to link the current ticket with another one in a different project. For example, to link a Jira Service Management ticket with a Jira ticket:
After executing the rule, the audit log of the automation rule shows the error message.
Cause
This error may occur because the Rule Actor doesn't have the "Browse Projects" permissions in the project of the ticket that will be linked.
For example, "User1" who is the Rule Actor:
The example user is not part of any of the Project Roles that have the "Browse Projects" permission in the destination project (where the ticket to be linked resides):
Solution
To fix it, you may apply one of the following two suggestions:
Option 1: Add the Rule Actor user to the "Browse projects" permission in the project:
- Go to Project Settings > Permissions.
- Click on the "Actions" button and select "Edit Permissions". More information about editing project permissions can be found here.
Option 2: Add the Rule Actor user to one of the existing Project Roles that are allowed to browse the project.
- Go to Project Settings > People.
- Click on "Add People".
- Search for the user.
- Select the desired role that has the "Browse projects" permission. For example, "Service Desk Team".
- Click on "Add".
More details about adding people to a project can be consulted here.