Error received when trying to save a workflow in the team managed Jira Project
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When trying to save the workflow in the team managed Jira project, sometimes we get the error "We couldn't save your changes". This article explains one such scenario and the troubleshooting steps along with the solution to this error.
Environment
Jira Cloud.
Diagnosis
If we inspect the backend logs by accessing the Network logs of the browser, we will get the below error response in the POST request while performing the save in the workflow:
{
"errorMessages": [
"Missing parameter \"previousStatusIds\" in rule \"eeae5533-a4b7-446d-a21c-8662a88ff797\".",
"Missing parameter \"previousStatusIds\" in rule \"2c9776e5-7d67-4b60-b57b-37599bf20a5f\"."
],
"errors": {}
}
Cause
The above error signifies that there are 2 transition where the rule of Previous Status Condition is incorrectly applied.
Unfortunately, the ID's don't help in a direct way to pinpoint to the rule that is causing the problem. However, it indicates that at least one of the rules "Previous Status Condition" has either of the below:
- An empty value in the field for the 'status'.
- A status that has been deleted.
Solution
We have to manually check all the transitions with the the rule of Previous Status Condition and find the corrupt transition where maybe the rule has empty statuses entered. For example:
We have to remove the rule from any such transitions and then the workflow will be available to be edited and saved again.