Error when trying to create a Slack channel from an Incident or JSM Chat settings
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
When trying to create a Slack channel from an Incident, the error message below appears:
"We couldn't create the chat channel. Wait a moment, then try again." or "Bot does not have permission to create channel"
Possible Causes
Cause 1
The Jira app does not have permission to create a new public Slack channel.
Cause 2
The Jira Service Management ChatOps Slack app has either been removed or deactivated in the Slack workspace.
Solution
Cause 1 Solution
Change the permissions for creating new public channels on Slack. Following Slack guide to Adjust channel management permissions:
- Ensure the Account Type associated to Atlassian Assist (by default Member) has both permissions:
Changing the permissions should enable the ability to create a Slack channel from an incident.
Cause 2 Solution
Reactivate the Jira Service Management ChatOps on Slack (if it is deactivated).
Reestablish the Slack connection with Jira by executing the following steps in order:
1) In the Jira Service Management Project, remove the Slack workspace connection from Project Settings → Incident Management → Communication Preferences.
2) Remove the Slack workspace connection from Jira Settings (Cog Icon) → Products → Chat and video tools.
3) Add the Slack Workspace back to Jira Settings (Cog Icon) → Products → Chat and video tools.
4) Add the Slack Workspace back to Project Settings → Incident Management → Communication Preferences.
NOTE
- The above steps will restore the ability to create chat rooms in Slack only from NEW incident tickets created after the connection is reestablished.
- Any chat room links on existing Incident tickets prior to the disconnection and reconnection will be wiped out! In other words, users will not be able to click into Slack directly from the Incident ticket.
- The chat rooms created in Slack from the Incident tickets, however, are preserved and users can still navigate to those directly in Slack when needed.
- There is currently no way to preserve or back up / restore chat channel links from the Incident tickets prior to reestablishing the connection. An open Suggestion exists to track the requested changes:
- JSDCLOUD-13361 - Preserve or restore Slack Chat Channel links if the connection to JSM Chat Ops is interrupted.