Error while importing Issue via CSV import: ERROR - Fatal error during import: Cannot invoke "com.atlassian.jira.issue.Issue.getIssueType()" because "issue" is nul
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Encountered with ERROR - Fatal error during import: Cannot invoke "com.atlassian.jira.issue.Issue.getIssueType()" because "issue" is null when attempting to import Issue via CSV Importer for specific issue Type or most of the issue Type
Environment
Jira cloud
Diagnosis
Ensure to perform the below checks :
- When attempting to create an issue with the same issue Type and Field values from UI (Issue create screen), is the user able to create an issue?
- If no, then please check whether the error on the Issue Create screen points to any specific field or user or group-related error. Sample error on Issue create screen for 2 dummy fields required by Validator is below:
- If so, please review the respective workflow transition for "create" and check the respective validator /conditions that are blocking the create action.
Cause
Validator/condition set on workflow for Create transition resulted in holding creation of Issue.
Solution
In order to fix it:
- You can pass the input for desired fields in a CSV file as per the recommended setup in the validator or condition
- Or can remove them from transition.