Error while inviting new users to cloud site "You've reached the maximum number of users for one of your products. To add this user, upgrade your plan."
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Inviting new user to the Atlassian cloud site , sometimes fails with the following error: "You've reached the maximum number of users for one of your products. To add this user, upgrade your plan."
Environment
Jira Service Management Cloud, Jira Work Management Cloud, Jira Software Cloud and Confluence Cloud
Diagnosis
The product has some licenses left, but still the error is reported.
Cause
This happens because there is a group added as default access for 2 products. Adding someone to this group will consume license for the 2 products at the same time.
Solution
To prevent this from happening, we need to use another group as a default access group for one of these products and then remove the affected group from that product. To learn more see How does product access work?
- From your cloud site, navigate to the user management by clicking on the Settings Icon from top right, next to your avatar and choose > User management
- Click on Product access option under the section Site Settings
- Find the group that has "default access group" tag for more than one product
- For one of the affected products:
- Have a new group added that has same member list as this group to make sure existing users do not lose any product access
- Add the new group as default access group for this product
- Remove the previous groups from this product
Removing a group will revoke product access for the group members unless they are already part of another group added under that product.
- Try enabling the product access again for the user
For any questions, please contact Atlassian support https://support.atlassian.com/contact/#/