"Escalate issue" button isn't visible on some issues
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
With the new feature of enabling developer escalations within a service management project, sometimes the "Escalate issue" Button isn't visible on the issue view. This article explains the cause and solution for such scenarios
Environment
Jira Service Management Cloud
Diagnosis
Project admins can enable developer escalations for their projects to facilitate smooth collaboration between developers and customer service agents.
Details are available on
Cause
The intent of usage is to allow agents to escalate an issue when they need help from developers. While configuring developer escalations, a common mistake is to add the request type of Developer escalations to any of the portal groups.
This allows the request type to be visible on the portal. Creating these requests directly would align them in the Developer escalations queue, and the button is not visible on these tickets.
The idea is to allow the creation of these tickets from the issue view to other issue types/request types therefore it should be hidden from the portal to avoid accidental creations that end up directly in the Developer Escalations queue.
Solution
Hide the request type from the portal by removing it from any/all portal groups.