'Failed to load' error when uploading attachment through JSM Form


Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary :

"Failed to load attachment" error in the issue view when adding an attachment through the JSM form while creating a ticket.

Environment

Jira Service Management- Cloud

Diagnosis


Getting the below error in developer tools while uploading a file through the form:

{
    "error": {
        "code": "NotFoundError",
        "title": "The entity with the given id does not exist",
        "href": "https://api.media.atlassian.com#NotFoundError"
    }
}


Cause:

  • If the issue workflow has jira.issue.editable property set as false in the very first status of the workflow stops the adding of attachments after the creation of the issue. This gives a "Failed to load" error in the attachment under the issue view.
  • For more details regarding the status property check this article : 




Solution:

To avoid this issue, modify the workflow property and remove the jira.issue.editable property from first status.

Follow the below steps to modify the property:

  1. Login as a Project Administrator;
  2. Go to Project settings > Workflows;
  3. Select the affected workflow;
  4. Navigate to the first status of the workflow which has the jira.issue.editable property set.;
  5. Click on the status > Go to properties and delete the property;
  6. Publish the workflow to save the changes.


To continue to restrict editing of the issue with this solution, use this workaround

  • In case it's necessary to restrict any edits in the issue after the issue creation, Add a new status without any properties before the current first status(with jira.issue.editable property) and use automation to transit from the New status to the First status.






Last modified on Jan 4, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.