Field 'development' does not exist or you do not have permission to view it when using the JQL Advanced search

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The JQL Advanced search is not accepting Development Tools search using the syntax development[pullrequests].open recommended on Advanced searching - development fields reference.

The JQL autocomplete does not work and it returns the error message "Field 'development' does not exist or you do not have permission to view it".

(Auto-migrated image: description temporarily unavailable)

Diagnosis

1 SELECT * FROM "CUSTOMFIELD" where cfname = 'Development';
  • The query should return an output similar to:

ID

CFKEY

CUSTOMFIELDTYPEKEY

CUSTOMFIELDSEARCHERKEY

CFNAME

DESCRIPTION

DEFAULTVALUE

FIELDTYPE

PROJECT

ISSUETYPE

10000

null

com.atlassian.jira.plugins.jira-development-integration-plugin:devsummary

com.atlassian.jira.plugins.jira-development-integration-plugin:devsummarysearcher

Development

Development Summary Field for Jira Software use only.

null

null

null

null

  • If the column CUSTOMFIELDSEARCHERKEY is empty, the autocomplete and the search will not work.

Cause

It is unknown how the data got into this state.

Workaround

JQL supports querying issue properties, and Development tools populate fields in Lucene that looked like issue properties (e.g. issue.property[development].commits).

Some samples of search using issue properties:

1 2 3 4 issue.property[development].reviews > 0 issue.property[development].commits > 0 issue.property[development].openprs > 0 issue.property[development].prs > 0

Solution

Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

  • Stop Jira;

  • Update the column CUSTOMFIELDSEARCHERKEY with the expected value:

1 2 update "CUSTOMFIELD" set "CUSTOMFIELDSEARCHERKEY"='com.atlassian.jira.plugins.jira-development-integration-plugin:devsummarysearcher' where cfname = 'Development'; commit;
  • Restart Jira.

Updated on April 2, 2025

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