Filter owner unable to edit or save filter
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Filter owners are unable to edit and save their shared filters. The following error is displayed on the screen after clicking Save:
The filter <FilterName> could not be saved.
Environment
Jira Cloud
Diagnosis
If the user has access to the browser's Developer Tools while reproducing the issue, an entry in the Network tab will contain the following Response:
{"errorMessages":[],"errors":{"shares":"You do not have permission to share. All shares are invalid.","shares_delegated":"The user 'UserName' does not have permission to share. The owner has not been changed."}}
Cause
The user no longer has the correct permission to share filters.
Solution
Ensure the user meets the criteria for the Share dashboards and filters global permission.
Additional Information:
Manage global permissions: https://support.atlassian.com/jira-cloud-administration/docs/manage-global-permissions/