Filters break after renaming issue types at the Epic level


Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.


Summary

Existing JQL filters that include issue types (such as the "issuetype = epic" clause) break when organizations rename issue types at the Epic level in company-managed projects.

Environment

This applies to Cloud only. 

Diagnosis

If:

  • your site uses JQL filters that reference the issue type (such as the issuetype = epic clause) and

  • your administrator recently renamed the issue type

Then:

  • your filter won’t return any results.

Cause

JQL looks for issue types according to their name. If an administrator renames an issue type at the Level 1 hierarchy, the query in your filter no longer matches the name of the issue type.

Solutions

  1. Revert the change to the status names.  Once reverted, the JQL filters should then result the expected results as they previously did.
  2. Update your JQL filters to include the new status name of the issue type previously called Epic.  If you want other issue types that sit at the Level 1 hierarchy level to be included, you’ll need to add them to your queries as well.





Last modified on Apr 11, 2024

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