Form date format is not the same as Jira date format

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

While using forms in Jira Service Management, the form date format may not be the same as the Jira date settings. For example, while using English UK, the format should be dd/MM/YYYY, but the customers are seeing d/m/yy on the portal.

We had a bug that was fixed: JSDCLOUD-11103 - Forms date format is not the same as Jira date format

Yet, you may find scenarios where this still occurs. This article explains the reasons behind the variation in formats despite addressing the bug, as well as the steps to resolve it.

Environment

Jira Service Management Cloud

Cause

This problem arises from our new feature, Multilingual Form.

This feature is only available with Jira Service Management Cloud and to those participating in the early access program (EAP) for form translations in Jira Service Management

As per its current behavior, administrators must provide a translated version of the form for any supported language (locale). Failure to do so will result in the locale falling back to the "form primary locale," which is set as the project's default locale.

For instance, if the project has the default language set to en-US, the "form primary locale" is automatically configured to en-US upon form creation. When you navigate to the "Translate" tab in the form builder and select "add language", you will observe that the "form primary locale" is displayed as en-US in the top left. As there is no UK translation available for this form, when a UK customer accesses the form from the portal, the system will be unable to locate the form in en-UK and will default to the "form primary locale," which is en-US affecting the date format.

Solution

There are two options available adding translations to the form by following the steps outlined in Add translations to a form.

Option 1: Add a UK form translation

  1. Navigate to "Translate" in Form Builder (Project settings > Forms > select the form > Translations)


  2. Click "Add Language" and add the language you want to enable
  3. Toggle on "Available to customers"
  4. Update the translation as you see fit and save changes


  5. Go to Project Setting > Language Support setting (Or follow the link in the warning icon in the Translate tab)
  6. Add the same language added in Step 2 and enable it at project level

Option 2: Set the "form primary locale" to en-UK

  1. Navigate to "Translate" in Form Builder (Project settings > Forms > select the form > Translations)
  2. Click "Add Languages" and add a language of your choice
  3. Update the "Primary Language" on the top left to "English (UK)"


  4. Click the Trash icon to delete the unwanted language translation and save changes

A demo of the Multilingual Form can be found below:


Last modified on Jan 23, 2025

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