Forms not adding to issue via automation

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

An automation rule configured to attach multiple forms on issue creation doesn't attach all the forms as configured. 

This happens to be a known bug at our end:

This article serves as a workaround for the above bug.

Environment

Jira Service Management, Automation.

Diagnosis

In automation, all actions execute in parallel. Therefore, the point-in-time copy of the issue and therefore multiple attach or copy actions can lead to some actions being overwritten.
For example:
An issue A is created and an automation rule to add forms F1 and F2 is triggered.
Now, the Attach Form action would work as follows: A → F1 and A→ F2, as parallel executions, and therefore one might overwrite the other.

Cause

Parallel executions of all actions.

Solution

A simple solution is to use the recently added Delay action (available only for all Premium and Enterprise) before the attach/copy action of the second form, to introduce a delay/buffer before the next execution. The same results could also be achieved by a Re-fetch issue data action:


Sometimes if you're adding more than 2 forms, you might need to add the extra delay/buffer by using multiple re-fetch data actions.



Last modified on Jan 23, 2025

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