Get an internal server error message when trying to create a new issue through REST method

Still need help?

The Atlassian Community is here for you.

Ask the community

Problem

After trying to create a new issue through REST API, the following error appears in the terminal:

{
"errorMessages": [
"Internal server error"
],
"errors": {}
}

Diagnosis

Start by making sure the json data are valid by referring the tutorial page.

You may also refer to atlassian-jira.log for a more complete error message or likely a java stack trace to help determine the root cause.

Additionally, you can enable HTTP access logs and HTTP dump logs on Logging and profiling page and run a test - this will create atlassian-jira-http-access.log and atlassian-jira-http-dump.log files. Note that this will produce a lot of logging and we advise against leaving it enabled.

Cause

The problem is the JSON data are not completely correct or Jira is unable to generate a valid response for the request.

Resolution

Refer to the JIRA REST API official documentation for more examples.

Last modified on Feb 15, 2022

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.