Getting the error "Field does not belong to the Request Type." when clicking on "Edit fields" to edit a Service Management Request Type

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

In a Service Management project, whenever a new Request Type is created, the error  "Field does not belong to the Request Type." is displayed in the UI when clicking on the "Edit fields" button:
 

Diagnosis

  • This issue only impacts newly created Request Types, not the current Request Types.
  • If the following query returns any row, then this knowledge base article applies to you:

    select * from fieldlayoutitem where isrequired = 'false' and fieldidentifier = 'summary';

Cause

The system field "summary" is set to "non-required" in a field configuration scheme in the database, although this field should always be required, as it is not possible to make it optional from the Jira UI. Due to this data inconsistency, the Request Type. Due to this irregular situation which is not expected by the Service Management application, this causes some data inconsistency and it becomes impossible to the edit the fields of any newly created Request Type.

Workaround

  1. Run the following query to determine which field configuration(s) is/are impacted by the non-required summary field issue. Note the ID(s) from the id column. This information will be used in Step 4.

    select * from fieldlayoutitem where isrequired = 'false' and fieldidentifier = 'summary';
  2. Stop Jira

  3. Create a backup of your database, so that you can revert the database changes if anything go wrong
  4. Run the following query in the database:

    update fieldlayoutitem set isrequired = 'true' where id in (LIST_OF_IDS_OBTAINED_IN_STEP_1>) and fieldidentifier = 'summary';
  5. Start Jira

  6. Create a new Request Type and try to edit it. You should now be able to edit the fields from this Request Type.

If the problem persists, or if the query from the diagnosis step did not return any row, please reach out to Atlassian Support via https://support.atlassian.com/.


Last modified on Nov 23, 2020

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