Global Automation error: Jira was slow to respond, because the JQL query returned too many issues


Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

Scheduled Automation rules failing with errors:

Jira was slow to respond, because the JQL query returned too many issues. Narrow the scope of this JQL query and try again:
resolution = Unresolved AND updated <= -7d AND assignee is not EMPTY AND status = "Backlog"

These are Global automation rules. The rule generally works fine when scope is - (Manual projects)

However, the rule fails when the scope is - Project categories (Servicedesk or Software) / Global.

Environment

Jira Service Management Cloud 

Diagnosis

  • Manually running the Automation rule might fail or take longer (~60 seconds) to execute. 
  • HAR file captured while running the Automation manually will have below 400 errors and "jqlTooComplex" response:

    • Request
      Request URL:https://<URL>/secure/QueryComponent!Jql.jspa
      Request Method:POST
      Status Code:400
      Remote Address:<IPAddress>
    • Response
      {
        "errorMessages": [
          "jqlTooComplex"
        ],
        "errors": {}
      } 

Cause

  • Try accessing Application link within the site and you might encounter "Something went wrong" error, as below:
  • Verify the invalid or corrupted Application links to Jira application that you might have

Solution

Remove or re-add the corrupted application link


Last modified on Nov 28, 2023

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