How to Add Parent Key value in New issue view navigator.
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
The new issue view navigator doesn't allow a view of the parent key during filter search results;
- With the new issue view navigator, Click on the filter
- Click on view all issues and now search for issues (query - issue type = subtask) using JQL/basic search.
New issue navigator:
Old issue navigator:
Environment
Jira Cloud
Cause
Due to a change in the issue navigator view, now it's not possible to view the parent key field during the filter search results.
Solution
First we need to create a new custom field and then use automation to transfer the parent key value into a custom field from the current parent field. Please check the below steps for your reference.
- Navigate to Setting -> Issues -> Custom field.
- Create a custom field of text type (parent key) and include all the project screens as per your requirement.
- Now, use the automation to populate the value of the parent key field based on the value of the parent field.
- Include the parent key field during the filter query search result.
Automation rule screen-shot for your reference.
The output of the filter query search for your reference.