How to change the Reporter for a JSM - SYNC?


Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

In the project, there is an automation rule in place that adds a comment to the issue to prevent breaching the SLA. Simultaneously, a SYNC is configured with an external site using the same user responsible for the automation rule.

Cause

The SLA includes a condition to verify if a comment has been added for the customer: "Comment: For Customers". However, since both the user executing the rule and the author of the comment are the same, this condition will not successfully fulfill the SLA.

Solution

Solution 1:

The Sync feature automatically assigns the authentication user as the reporter for any new issues it creates. To address this issue, it is necessary to update the user used for configuring the Sync.

Steps to follow:

  1. Go to Settings > Products.

  2. Select Syncs from the sidebar (under Operations). You’ll be able to view already created syncs of all teams on that Jira site.

  3. Select the Sync > Edit 
  4. Sync Settings >

Solution 2:

Modify the user responsible for executing the rule that adds a comment to the issue, that is, change the Rule actor.

Steps to follow:

  1. Navigate to the automation list.

    • For project automations, go to Project settings > Automation. In a team-managed service project, go to Service project settings > Automation.

    • For global automations, go to Jira home > Settings > System > Automation rules

  2. Select the rule you want to configure.

  3. Under Actor, search for the user you want to choose to be the actor for this rule. 

References:




Last modified on Oct 11, 2024

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