How to enable and edit component/s , affects Version/s and fix version/s field ?

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Symptoms

By default, when a user creates an issue in a new project, these three fields are disabled in the Create Issue screen. It is impossible to add a value on that screen.

Please refer to the screenshot below, notice the Component/s , Affects Version/s , Fix Version/s field.

Cause

This is not a global/system administrator configuration. These three fields are tied to the project. 

Resolution

  • Users will need to manually add these field values before creating an issue.
  • This can be done at the appropriate project's Administration page.

  • Here are the steps you may follow :

 

Versions

  1. Click on Projects -> Choose the appropriate project
  2. At the Project Summary Page -> Click on the Administration tab
  3. On the left pane , click on Versions
  4. Fill in the Name of the versions and Description then click on the Add button
  5. Repeat Step 4 until you are done adding all the versions.
  6. Now every time you Create a new issue on this project you will be able to have access to the Affects Version/s & Fix Version/s field.

 

 

  •  This is the same for the components field.

 

Components

  1. Click on Projects -> Choose the appropriate project
  2. At the Project Summary Page -> Click on the Administration tab
  3. On the left pane , click on Components
  4. Fill in the Name , Description, and Component Lead then click on the Add button
  5. Repeat Step 4 until you are done adding all the compenents.
  6. Now every time you Create a new issue on this project you will be able to have access to the Component/s field.

 

 

Last modified on Feb 19, 2016

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