How to fix This user is not in jira so can not add a comment Warnings
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When a user makes a comment by replying to a mail notification, the process fails with errors like:
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2008-07-08 14:11:17,625 JiraQuartzScheduler_Worker-0 WARN [service.util.handler.AbstractCommentHandler] The mail 'FROM' does not match a valid user
2008-07-08 14:11:17,641 JiraQuartzScheduler_Worker-0 WARN [service.util.handler.AbstractCommentHandler] This user is not in jira so can not add a comment: System Administrator <abc@localhost.net>
Cause
There are two parameters which have not been entered when defining the service that handles comments made via email.
Resolution
Add the reporterusername or createusers parameter. The full instructions for setting up this feature can be found in our Creating Issues and Comments from Email documentation.
OR
Set the
to allow 'Anyone' to comment.
You may wish to enhance this with a customisation to add Appending Email Addresses to Comments Made by Anonymous Users when Using a Mail Handler.
See also Unable to create Jira issue using an Incoming Mail Handler because the sender of the email is anonymous for a related article on creating issues as an anonymous user.
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