How to Migrate a Text Field to a User Picker Field in Jira


Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

Users may need to migrate from a text field to a user picker field in Jira, particularly when a field like "Jira access email" (For example) has been used in multiple issues, and there is now a requirement to switch to a user picker field.

Environment

Jira Service Management (Cloud)

Diagnosis

  • The user attempted to change the custom field type from "text" to "user picker" in Jira.
  • Jira currently does not allow changing the type of an existing custom field once it has been created.

Cause

  • Unfortunately, as of now, Jira doesn't has the ability to change the field type. Once a custom field is created you cannot change the type anymore and you will need to create a new field with the type User picker. We, however, have an open feature request for our developers to include the feature of changing the field's type and it can be tracked here-

Solution

  • Create a New User Picker Field:

    • Go to Jira administration and create a new custom field of type "User Picker."
  • Data Migration:

    • Option 1: Import/Export
      • Export all issues containing the text field using Jira's export function.
      • Map the text field values to the new user picker field during re-import.
      • Delete the old text field after the migration is complete.
    • Option 2: Automation Rule
      • Set up an automation rule in Jira to schedule the update of the new user picker field with values from the existing text field.
      • Use smart values to reference the text field in the automation.
Last modified on Aug 31, 2024

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