How to retain user information on the issue comments made by former users during CSV import between sites?
Summary
While importing comments via CSV import between two Jira sites, from users that are deleted on the source site, the comments get created on the destination site with the currently logged-in username.
The issue gets imported on destination site with below errors -
2024-10-07 12:45:29,804 ERROR - Cannot create user xxxxxx: User xxxxxx has an invalid e-mail address [xxxxxxx@]
2024-10-07 12:45:29,816 ERROR - Cannot create user yyyyyy: User yyyyyy has an invalid e-mail address [yyyyy@]
2024-10-07 12:45:29,823 INFO - 2 users associated with import. All of them imported as inactive, this can be changed after import in User Access step.
Creating issue with currently logged in user instead 2024-10-07 12:45:32,861 WARN - Commenter named xxxxx:yyyyyyyy not found.
Environment
Jira Cloud
Cause
When the user is not added to the site, the below error is prompted after migration and the comments are created with author name of the user currently performing the CSV import.
Solution
To retain the former comment author information, invite the email addresses of the former users to the destination site. They don’t need to have active access; you can simply send the invite.
Steps to add a user to the Jira site-
- Navigate to https://admin.atlassian.com
- Invite the comment author to the site
Once the Import Data via CSV is completed, suspend or remove a user. This way, the comment information will be retained.