How to see total count of issues when using JQL and the result is greater than 1000
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When you filter and view issues via JQL in the "View All Issues" page and the number of issues returned is greater than 1000, you don't see the exact count of issues returned just 1000+. In this article, you will find a quick hack to see the total count of issues returned by the JQL by making a couple of modifications to the browser URL.
Environment
Jira Cloud.
Diagnosis
We currently have a feature request JRACLOUD-45639 - Allow the JIRA Issue Navigator to display more than 1000 results.
to make the count visible even if it is more than 1000. This hack will not be needed once the feature is implemented
Solution
- Go to Filters > View All issues
- Type in the desired JQL and hit Search
Now the URL in the browser should look similar to the one below
https://<yourdomain>.atlassian.net/issues/?jql=<encoded_jql_query>
- Now, in the browser URL, replace "/issues/" with "/rest/api/3/search"
Append the URL with "&maxResults=0" parameter. The final URL should look like below
https://<yourdomain>.atlassian.net/rest/api/3/search?jql=<encoded_jql_query>&maxResults=0
- Hit Enter
This will return a short JSON and in that, you will see the "total" property which will hold the total count of issues returned for your JQL. Here we are leveraging our REST API endpoint to get the count directly in the browser rather than making an API call through other means.