How to setup on call in customer portal
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
This article explains the method to display the on-call roster on the Jira Service Desk Portal so that external customers can view the roster. To understand and configure the On-call schedule, review the article: Build and manage on-call schedules.
Environment
Jira Cloud
Cause
The on-call schedule is available from the URL https://<<your-domain>>.atlassian.net/jira/servicedesk/projects/<<Project_Key>>/on-call-schedule and is configured to be displayed within the Jira UI. Only users with Atlassian Accounts and access to the Jira site will be able to view the On-Call schedule.
Solution
To enable the On-call feature from the service project:
- Please navigate to the URL: https://<<your-domain>>.atlassian.net/jira/servicedesk/projects/<<PROJECT_KEY>>/settings/itsm-features
- To enable the feature toggle the option in-line On-call.
- Once the On-call option is enabled under the feature we can see and configure the On-call page from the URL: https://<<your-domain>>.atlassian.net/jira/servicedesk/projects/<<Project_Key>>/on-call-schedule
Since it is not possible to access the On-call roster outside Jira UI, you will need to do the below:
- Manually create the roster in confluence - Create, edit, and publish a page.
- Enable public link for the individual Confluence page with the On-call roster - Share content externally with public links.
- Share this public link on the portal as an announcement, which will be displayed for all the users that have access to the portal.
Add an announcement to your portalAdding an announcement to the portal displays a message at the top of your portal to those with access to your service project. Project administrators can add announcements to the portal or they can also allow agents to do so. To add announcements to the portal:
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Add an announcement to your help centerAdding an announcement to the help center displays a message at the top of your Jira Service Management site’s help center. You need to be a Jira administrator to add announcements to the help center. To add announcements to the help center:
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Reference article: Add announcements to your help center or portal