Icons Missing in Internet Explorer 9/10/11

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Server and Data Center Only - This article only applies to Atlassian products on the server and data center platforms.

Problem

Many icons do not render properly in most pages such as the Issue Navigator or the Comment box, and this problem only happens on Internet Explorer 9/10/11 but not on other browsers.

Diagnosis

When replicating the issue in IE with developer tools, below error is shown in the console:

SEC7113: CSS was ignored due to mime type mismatch
batch.css


Cause

Internet Explorer did not render the page along with the CSS file, as a result the browser is unable to render the icons because the URLs to fetch the icon images are defined inside the CSS file.

Workaround

  1. Download FileTypesMan.

  2. Run FileTypesMan and search for .css file type from the list.

  3. Double-click to edit the settings.

  4. In the MIME Type field change the value to "text/css".

  5. Click OK.

Resolution 1

Recently, Microsoft released an update that broke a lot of features from IE browser.

To fix this this issue, they released a an out-of-band update to remediate the situation.

Check if you have installed the KB4052231: https://support.microsoft.com/en-us/help/4052231/windows-10-update-kb4052231

Resolution 2

Check if in your environment you have some Font related Domain policies.


Last modified on Dec 13, 2018

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.