Import Section of Asset schema (icon keeps spinning)
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Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
This article describes a problem observed in Assets with one of the object schemas. The icon keeps spinning when the "Import" tab is selected.
Environment
JSM 5.4.x
Diagnosis
- Capture the HAR file while browsing this Import tab of Configure schema in Assets.
- Look in the HAR file to check on each import configuration, there is a REST call to fetch details.
<base-url>/rest/insight/1.0/importsource/objectschema/<objectschema-id>
- Check the screenshot for reference.
- Further, if we compare the payload with the number of import configurations in UI, we find that the number of entries is higher in the payload tab of the request in the HAR file. This observation shows the response is being properly received, however not all import configurations are being displayed in UI.
Solution
- Delete the import configurations that are not being loaded in Asset's import configuration UI.
- After deleting the import configuration with id 10 the issue was resolved in this case. There was no need to delete the other remaining extra configurations. The deleted configuration needs to be recreated manually.
- Deletion can be executed using the following REST operation. After executing this command, check the import configuration page, now the page should load completely with all import configurations.
curl -v -su "user:password" -X DELETE <base.url>/rest/insight/1.0/importsource/10