Importing attachments into JIRA Cloud applications using CSV files

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This Knowledge Base article is written specifically for the Atlassian Cloud platform. Due to Functional differences in Atlassian Cloud, it is not applicable to Atlassian Server products.

Problem

Using the basic CSV import process, JIRA Cloud applications display a similar error message to the following when trying to import attachments:

An exception occurred dealing with "<attachment.url>"


Diagnosis

The file contains references to attachments that are hosted on an instance that is not publicly accessible.

Cause

As the files are not publicly accessible, the JIRA Cloud application is unable to retrieve them.

Resolution

To resolve this issue, you can either fix the CSV file, or import the attachments separately.

Fix the CSV file

  1. In the CSV file, specify the URL of each attachment in the attachments column.

    For example, in this file, the attachment is stored in https://jira-server:8080:

    Assignee, Summary, Description, Attachment, Comment
    Admin, "Issue demonstrating the CSV attachment import", "Please check the attached image below.", "https://jira-server:8080/secure/attachment/image-name.png", "01/01/2012 10:10;Admin; This comment works"
  2. Import the CSV using the steps in Importing data from CSV.
Last modified on Sep 19, 2018

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