Incoming Call Integration is not able to route calls to more than one number

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

We have integrated incoming call routing with Opgenie using the Twilio number as mentioned in the below public document. However, while testing this integration the call is getting routed only to the owner of that Twilio account, but not to any other users.

Diagnosis

  • Started analyzing Opsgenie logs and noticed the below message, which speaks about numbers being unverified:-
    [system] Couldn't dial 31-XXXXXXXXX; reason: Code[21219]: The number +31-XXXXXXXXX is unverified. Trial accounts may only make calls to verified numbers.
  • When we checked the user profile on Opsgenie(settings> users >select the user > notification tab), the number is verified correctly.
  • Upon investigating further, noticed that we have verification on Twilio as well:- 

Cause

Solution

  • Converting the trial account to an upgraded one on Twilio will allow us to make calls without any caller ID verifications.



Last modified on May 15, 2023

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