Insight functionality not working and actions resulting with errors due to "Version can not be null" error

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

    

Summary

Insight functionality not working and actions resulting with "Something went wrong. Contact administrator" errors.

It is not possible to create or edit objects, and configuring Insight on Insight Configuration page also gives the same error.
screenshot-1.png

Environment

  • Insight 8.x

  • Jira Service Management with embedded Insight

Diagnosis

In Jira logs, we see the following error appearing:

2021-12-16 13:53:52,325+0100 http-nio-8080-exec-3 ERROR admin 833x332x1 1eapb8x 10.5.22.196,10.5.17.150 /rest/insight/1.0/global/config [c.r.j.p.i.c.w.a.r.exception.mapper.DefaultMapper] Unexpected exception was thrown while processing the request
java.lang.IllegalArgumentException: Version can not be null
at io.riada.insight.model.VersionString.<init>(VersionString.java:30)
at com.riadalabs.jira.plugins.insight.common.property.PropertyManagerImpl.currentInsightVersion(PropertyManagerImpl.java:117)
at io.riada.insight.services.GlobalConfigurationServiceImpl.getInsightGlobalConfigModel(GlobalConfigurationServiceImpl.java:106)
at com.riadalabs.jira.plugins.insight.channel.web.api.rest.services.globalconfiguration.GlobalConfigurationResource.getConfig(GlobalConfigurationResource.java:65)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
... 19 filtered
at com.atlassian.plugins.rest.module.RestDelegatingServletFilter$JerseyOsgiServletContainer.doFilter(RestDelegatingServletFilter.java:160)
... 1 filtered
at com.atlassian.plugins.rest.module.RestDelegatingServletFilter.doFilter(RestDelegatingServletFilter.java:70)
... 32 filtered


Cause

There are several known causes for this problem.

Cause 1

Jira database gets misconfigured or some data does not get fully restored, during Jira migration or installation.

Cause 2

If Jira is installed with MySQL database, the problem can occur due to sql_mode parameter parameter set to "NO_AUTO_VALUE_ON_ZERO"

Solution

Solution for Cause 1

Re-try the installation / migration from scratch, after setting up a fresh, empty Jira database.

Solution for Cause 2

Make sure that to remove sql_mode parameter MySQL configuration parameter, if being used. Refer to Connecting Jira applications to MySQL 8.0 for more information.


Last modified on Feb 22, 2022

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.