Insight plugin becomes disabled after updating to Jira Data Center license
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After upgrading Jira Software Server 8.20.1 to Data Center license the Insight - Asset Management plugin stops running.
Environment
Jira Software 8.15 and above - Server license
Insight - Asset Management installed
Diagnosis
Starting from Jira 8.15.x the Insight - Asset Management plugin is bundled with any JSM 4.15.x DC install.
Cause
From the 8.15 release Insight - Asset Management comes bundled in the DC installs with JSM 4.15 and above.
As a result, any DC install of 8.15 or later requires that JSM be installed for Insight - Asset Management to function. This is only a requirement for DC installs.
When updating to a DC license from a Server license on Jira versions above 8.15.x, the Insight - Asset Management plugin on a server license will require JSM to be installed.
Prior to 8.15.x where Insight - Asset Management is not yet bundled, there is no JSM requirement. Once the DC license is applied to a Jira 8.15x and above instance, the requirement for JSM becomes active when Insight - Asset Management is installed.
Solution
Install the corresponding JSM version on the instance. This installation will prompt Insight to update to the bundled release and becomes active.