Insight scheduled tasks (eg: imports) not processing

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Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Administrators may find that their scheduled tasks in Insight may not be processing and executing in their environment. As an example; in these situations, scheduled imports may not be running at the time they are scheduled to run and are seemingly skipped.

Environment

Jira Service Management Data Center with Insight.

Diagnosis

Scheduled imports for import types like LDAP, Insight Discovery are not being run and as a result any imported data expected is not available.

Cause

A possible cause for this behaviour is that the "Dedicated Scheduling Node" for these tasks is not configured correctly within the Insight configuration.

This may occur when nodeID has been updated / changed.  

Solution

To check your Dedicated Scheduling Node settings, as an administrator:

  1. Go to your configuration cog in the top-right and select Manage Apps
  2. From the side-bar, select Insight Configuration
  3. From the list of option which appear, check the setting for "Dedicated Scheduling Node". Ensure that the node name listed here is correct and valid
    (info) If the "Dedicated Scheduling Node" setting is set to "Not configured", this means that Insight will choose any available node and you are not impacted by this configuration issue
    (info) If you need to check the list of valid node names, go into your System Configuration and select "Clustering" from the side menu for a list of valid node names
  4. If the node name listed is incorrect, click Edit Settings
  5. Scroll down to the bottom of the page to the "Dedicated Scheduling Node" setting and select the desired node from the drop-down list
    (info) If you do not want to specify a node, ensure that the field is empty. This will set the option to "Not configured" which means that Insight will choose any available node
  6. Click Save

If you updated the settings here, wait for the next scheduled task to process and ensure that it has run correctly.


Last modified on Apr 11, 2023

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