Installing Jira Software or Service Management while Jira Core is running fails with "Jira Software / Service Management is currently unavailable. This might be because an upgrade task has failed to run or has not yet completed."

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Admins are given the possibility to expand the Jira capabilities by installing Jira Software or Jira Service Management on top of Jira Core.

The installation is possible at runtime so admins don't have to shutdown Jira Core to perform the installation. 

In some corner cases, the installation fails and Jira throws the following error message in the UI: 

Jira Software is currently unavailable. This might be because an upgrade task has failed to run or has not yet completed.

Diagnosis

  • No relevant log messages are logged on the server side. 
  • If you're running Data Center, you may end up with Jira Software / Service Management installed in only a subset of the nodes.
  • Jira Software / Service Management functionality is not available. 

Cause

We are unable to reproduce this behaviour so we don't know the root cause. 

Workaround

To achieve a successful installation of Jira Software / Service Management, proceed as follows: 

  1. Put Jira in safe mode
  2. Stop Jira
  3. Take a backup of the plugins directory <Jira-local-home>/plugins/installed-plugins (For DC: <Jira-shared-home>/plugins/installed-plugins)
  4. Delete all plugins from the folder
  5. Delete all the plugins temp directories:
    • <Jira-shared-home>/plugins/.bundled-plugins/ (DC only)
    • <Jira-shared-home>/plugins/.osgi-plugins/ (DC only)
    • <Jira-local-home>/plugins/.bundled-plugins/
    • <Jira-local-home>/plugins/.osgi-plugins/
  6. Download an uncompress the Jira Software / Service Management OBR from:
     If you're installing Software and Service Management, install them one by one and not at the same time. 
  7. Move all of its JAR contents to the plugin directory
  8. Start Jira and validate Jira Software / Service Management functionalities
  9. Stop Jira
  10. Move all the JAR in the backup of the installed plugins directory into <Jira-local-or-shared-home>/plugins/installed-plugins
     Make sure you don't overwrite any existing ones when copying the JARs (Tip: On Linux, use cp -n).
  11. Start Jira
  12. Exit safe mode
  13. Validate all Jira functionality is there


DescriptionInstalling Jira Software or Service Management while Jira Core is running fails with "Jira Software / Service Management is currently unavailable. This might be because an upgrade task has failed to run or has not yet completed."
ProductJira 

Last modified on Dec 29, 2023

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.