Issue can not be opened Error When Trying to Select it in the Issue Navigator
Symptoms
When selecting an issue from the Issue Navigator, the following error is displayed:
XXX-#### can not be opened. The issue may have been deleted or you might not have permission to see the issue.
The following appears in the atlassian-jira.log
:
2013-01-01 00:00:00,000 http-bio-8080-exec-21 ERROR [500ErrorPage.jsp] Exception caught in 500 page null
java.lang.NullPointerException
at com.atlassian.jira.plugin.viewissue.AttachmentBlockContentRenderingInstructionsProvider.getInstruction(AttachmentBlockContentRenderingInstructionsProvider.java:46)
at com.atlassian.jira.plugin.issuenav.viewissue.webpanel.DefaultContentRenderingInstructionProvider.get(DefaultContentRenderingInstructionProvider.java:39)
at com.atlassian.jira.plugin.issuenav.viewissue.webpanel.WebPanelMapperUtil.mapAndRenderPanels(WebPanelMapperUtil.java:98)
at com.atlassian.jira.plugin.issuenav.viewissue.webpanel.WebPanelMapperUtil.create(WebPanelMapperUtil.java:60)
at com.atlassian.jira.plugin.issuenav.action.IssueAction.populateIssueFields(IssueAction.java:162)
Cause
There's a null value in the created column of the fileattachment table.
You can confirm this with the following query on your JIRA database:
select * from fileattachment where created is null;
Resolution
Always back up your data before performing any modification to the database. If possible, try your modifications on a test server.
- Stop JIRA
Run the following update statement on the JIRA database
update fileattachment set created = getdate() where created is null;
Note - for postgres databases run the following update statement on the JIRA database instead of the above
update fileattachment set created = now() where created is null;
Start JIRA