Issue Type Avatars Missing on Create Issue Screen
Symptoms
When creating a new Issue, custom Issue Type Avatars are missing (shows a blank/white box image) in the dropdown however throughout the environment (in the Issue Types Administration and Issue Details) the correct avatars are seen.
Diagnosis
If we run a Browser Inspector and look at the Console while viewing the Create Issue page, we see that the URL for the Avatar Images are not coming in correctly:
For some reason the URLs are being generated as: https://domain.atlassian.nethttp//path/to/the/image.png and obviously fail since they are invalid.
When we find the Avatar in the Issue Types Administration page, the URLs appear to be correct:
Workaround
A workaround was found by re-uploading the Custom Images for the Issue Type Avatars.
- Choose > Issues. Select Issue Types
- Edit the Issue Type that shows a missing Avatar when creating a new Issue
- Update the Issue Type Avatar by clicking on the select image link and upload the custom image
- Click Close and Update to finalize the changes.
If you do not have a copy of the avatars on your workstation, you can save a copy by going to the Issue Types Administration Page (Choose > Issues. Select Issue Types) and Right-Click and Save the needed avatar(s).