Issue while removing/adding a project from a priority scheme
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Issue while removing/adding a project from a priority scheme, the priority scheme page throws the below error message
We couldn't update the scheme
Refresh the page and try again.
Environment
Jira Service Management Cloud
Diagnosis
Check the permissions:
- Go to the project settings of the specific project.
- In the project settings sidebar, select 'Permissions.'
- This will take you to the 'Permission Scheme' page, where you can see all the permissions and the users/roles/groups that have been granted those permissions.
- Look for 'Administer Projects' in the list of permissions and check if your user/group/role is listed there.
If you're not included, you'll need to ask a Jira Admin or someone with Administer Projects permission to either grant this permission or add the project to the priority scheme.
Additionally, there are some troubleshooting steps to address this issue that is being experienced with Jira. These steps are crucial in identifying the root cause of the problem and finding a solution.
- Clear your browser cache and check if the issue persists. Cached data can sometimes interfere with the proper functioning of web applications like Jira.
- Try using Jira in incognito mode to eliminate any conflicts caused by browser extensions. Disable any browser extensions you have enabled and see if this resolves the issue.
- Test Jira in an alternative browser to determine if the problem is specific to your current browser.
- If you're using a VPN, temporarily disable it and test Jira again. Additionally, if possible, try accessing Jira from a different network to see if network configurations are contributing to the problem.
- If you're working from an office, contact your local IT team to verify the firewall settings. Firewall restrictions might be blocking access to certain features of Jira.
If none of these steps helps, then generate the HAR file and check the details in it. HAR Files contain a detailed record of all web requests and responses made by your browser while interacting with Jira.
Cause
There can be multiple reasons for this error to occur.
The Generated HAR file had the below error. (Refer to the document to generate the HRA file)
errorMessages": [],
"errors": {
"mappings": "The priorities with ID [1, 10002, 2, 10003, 4, 5] require mapping."
}
Solution
The above error message confirmed that "The priority with IDs [1, 10002, 2, 10003, 4, 5] requires mapping."
The priority in question here was 'Medium', 'High', 'low', 'lowest', 'Highest' and we linked this status to the to the priority scheme by following the below steps
To edit priorities associated to a priority scheme:
Select > Issues > Priority schemes.
Select > Edit for the scheme you want to edit.
You can:
Select to remove a priority.
Select Set as default to make the priority a default for the scheme.
Select Add priorities to associate more priorities to the scheme.
Select Save changes.
Reference: Associate priorities with a priority scheme procedure