Issues are not appearing in Boards

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Server and Data Center Only - This article only applies to Atlassian products on the server and data center platforms.

Problem

Issues are not appearing in the Plan or Work boards for either Scrum or Kanban.

Cause

  1. JIRA Software hasn't reindexed properly.
  2. The context of the Sprint custom field is not set to global.
  3. The Search Template for Sprint custom field is not set to JIRA Agile Sprint Field Searcher.
  4. Mapped columns to statuses are not mapped in the board's configuration.
  5. Only the first column is populated with statuses.
  6. The project has been renamed.
  7. The board's filter is blocking some issues.
  8. The sprint custom field is hidden through Field Configurations.
  9. 'Fix version' is set to 'Hide' in 'Field Configurations' page.
  10. The user does not have the appropriate permissions to view or edit those issues.
  11. There are Issue Types or Statuses that use integers (1, 2, 3 and so on).
  12. The Fast Transition functionality in the Script Runner plugin may be causing problems. This is a bug as tracked under GRV-232.
  13. If on Active Sprint section and no issues on currently running sprints, the board will be empty, but issues will still be listed on the backlog.

Resolution

  1. Make sure that JIRA Software is re-indexed (Full Reindex) - Search indexing.
  2. Set the Sprint's custom field contexts to 'Global' or to the projects to be used in JIRA Software. Refer Configuring a custom field for more information.
  3. Set the Sprint's custom field Search Template to JIRA Agile Sprint Field Searcher. Refer Configuring a custom field for more information.
  4. Map the columns in board's configuration to the correct status, please refer to Configuring columns for more information.
  5. Make sure your board has multiple columns populated, JIRA Software will consider the last column that's filled in as the end column. Please refer to Configuring columns for more information.
  6. Modify the board's filter to use the new project name or key - Configuring filters.
  7. Make sure there are no issues blocked by the board's filter - Configuring filters. If the board filter retrieves issues based on an additional field like customfield or label, ensure that each of the issues that should be shown in the board and their Epics has the correct customfield or label value.
  8. Make sure the sprint custom field is not hidden in the Field Configurations page - Specifying field behavior.
  9. See JIRA Software Kanban board does not show all Issues
  10. Verify the user has access to those issues with the JIRA Admin Helper plugin.
  11. Make sure there are no Issue Types or Statuses that are integers, as this is a known bug tracked under 
  12. If using the Script Runner plugin, verify the behavior as documented in GRV-232.
  13. Add issues to active sprints, https://support.atlassian.com/jira-software-cloud/docs/use-active-sprints/

Additional Troubleshooting

The following troubleshooting steps will also be helpful if the above does not resolve the problem:

  1. Try accessing the filter directly that is used for the board (Tools > Configure > Filter > Click on the Saved Filter).
  2. If results are returned, however, they are not returned through the board, it may be to do with additional causes. We can verify this by enabling some additional logging and then seeing exactly what JQL JIRA Software is using to return issues.
  3. Enable the extra JQL logging by setting com.atlassian.jira.issue.search.providers to DEBUG in Logging and Profiling.
  4. Reload the board. This will give you the JQL in the logs that JIRA Software is using in the logs, e.g.:

    2013-03-01 15:48:35,607 http-8910-9 INFO allyourbase 948x1325x2 5a6eo1 172.22.2.187 /rest/JIRA Agile/1.0/xboard/work/allData.json [issue.search.providers.LuceneSearchProvider] JQL query: {issuekey = "CDSSF-442"} AND {status in ("3", "1", "6", "5", "4", "10022", "10020")} AND {cf[10370] in openSprints()} order by Rank ASC
  5. Take that JQL and run it directly against the Issue Navigator. For example:

    issuekey = CDSSF-442 AND status in ("3", "1", "6", "5", "4", "10022", "10020") AND cf[10370] in openSprints() order by Rank ASC

    cf[10370] is the Sprint field in this example.

  6. This can help identify any problems with that JQL where the error may not be reflected in the board. In this particular example, the Sprint field was hidden on the Field Configuration and the below error presented in the Issue Navigator, but not JIRA Software:
  7. Fix the problem with the field configuration and test the board again.
Description

Issues are not appearing in the Plan or Work boards for either Scrum or Kanban.

ProductJira
PlatformServer
Last modified on Jan 11, 2021

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.