Issues Created via Mail Handler Do Not Respect Project's Default Assignee

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptom

Despite correct configurations of a project and mail handlers, the assignee of new issues do not get set as expected when created via a mail handler (whereas it gets set as expected through the web interface).

Cause

This occurs when a JIRA user account is registered as having the same e-mail address that the mail handler itself is using to pull messages from. Essentially, a registered e-mail address of a JIRA user account takes precedence over the 'Default Assignee' value for a project.

Resolution

Ensure each mail handler has a unique e-mail address for which it can receive messages, distinct from the address used by the mail handler.

Last modified on Feb 26, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.