Issues with adding users to the "Customers" section of a project.

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

 Issues with adding users to the "Customers" section of a project.

Environment

Jira Service Management Cloud. 

Diagnosis

In the Customers section of a project, Administrators or Agents may encounter an issue where they are unable to add 'portal-only accounts' or 'Atlassian account' users using the 'Add Customers' button. Alternatively, these users may be successfully added but then disappear after the page is refreshed. Furthermore, this issue may also result in these customers not appearing in the user picker fields, such as the 'Reporter' field.

Solution

For Portal-only accounts -

In the Portal customers page select the three dotted icon in front of the corresponding user and select Revoke access. Once revoked try to add the user in the customers section of the project.

For Atlassian accounts - 

Disabling and then re-enabling the site access to the Atlassian Accounts of those affected on the Administration Hub (https://<yourinstance>.atlassian.net/admin/users) will ensure these users appear correctly in the search results mentioned.


You can also give it a try by suspending and restoring access to the user -



In the event that the customer's account does not appear in the customers section or is not listed in the user picker fields during the addition process, we advise contacting our support team for prompt assistance.


Further reading -




Last modified on Jun 2, 2024

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