Jira server unable to retrieve messages from IMAP server with No login methods supported error

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

The JIRA application is unable to retrieve messages from an IMAP server and displays error messages like the following in the logs:

[service.services.mail.MailFetcherService] IMAP[#####]: Error connecting to host 'xxx' as user 'xxx' via protocol 'imap': javax.mail.MessagingException: No login methods supported!;

Cause

The Java mail library used by the JIRA application is not configured to use TLS for non-SSL connections by default. If you connect to an IMAP server without using SSL, and the server is not configured to allow unencrypted connections, you may see the error shown above.

Resolution

There are different ways to resolve this problem:

tip/resting Created with Sketch.

If following options 1 or 2 below, please follow the steps on Connecting to SSL services to import the Certificate from the IMAP server in order for the connection to work correctly.

Option 1:
Switch to using an SSL connection to communicate with your IMAP server.

Option 2:
If you are connecting to your IMAP server over a non-SSL connection (using STARTTLS), set the following property to the JIRA applications Startup Options:

-Dmail.imap.starttls.enable=true

Option 3:
Allow unencrypted communications between your JIRA application instance and your IMAP server (not recommended).

Last modified on Sep 25, 2019

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.