Jira cloud for excel add-in does not load on desktop and JIRA.JQL function changed


Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

'Jira Cloud for Excel add-in' does not load in the desktop version.


Sometimes all fields that previously had =JIRA.JQL() suddenly appears as =_xldudf_JIRA_JQL and trying to add the correct formula text back in results in a "#NAME?" error

Environment

Jira Cloud 

Diagnosis

Verify if the O365 version is the latest, update it if possible

https://docs.microsoft.com/en-us/office/dev/add-ins/concepts/browsers-used-by-office-web-add-ins

Cause

This can happen randomly or whenever there is an upgrade to O365 or Windows. However, uninstalling and re-installing the add-in does not fix the 'Jira Cloud for Excel add-in' load issue.

Solution

We will need to revoke access from Jira Cloud for the 'Spreadsheets app' here https://id.atlassian.com/manage-profile/apps. This would revoke the token, and then the next time the user tries "Get Jira Data" we would ask them to re-authorize.

If using Excel Desktop it may be necessary to clear the add-in cache by following the below steps:

File -> Options -> Trust Center -> Trust Center Settings -> Trusted Add-ins Catalogs and mark the following option:

2023-09-05_14-24-58.png


After reopening Excel Desktop, the add-in interface will loaded successfully.


If the issues persist after the above steps, Please Contact Atlassian Support



Last modified on Oct 16, 2023

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